Translate

2018년 11월 23일 금요일

[Chrome] ERR_SSL_VERSION_OR_CIPHER_MISMATCH 이슈 원인 및 해결방법






증상

 - 크롬을 이용해 SSL/TLS(https) 프로토콜 접속 시 아래와 같은 에러가 발생한다.


 ERR_SSL_VERSION_OR_CIPHER_MISMATCH

 지원되지 않는 프로토콜
 클라이언트와 서버가 일반적인 SSL 프로토콜 버전 또는 암호화 제품군을 지원하지 않습니다.










원인

1. 서버(WAS)에서 낮은 버전의 SSL을 사용하는 경우
1004lucifer
2. 서버(WAS)에서 응답한 Cipher Suites를 브라우저(Chrome)에서 처리 할 수 없는경우
  ( 링크 - Cipher Suites란 무엇일까? )







해결방법

1. 서버가 낮은 버전의 프로토콜을 사용하는 경우
  - 브라우저에서 낮은 버전의 프로토콜을 사용 가능하도록 옵션을 변경해 준다.
  (크롬과 IE는 같은 인터넷 옵션을 사용한다.)





2. 서버에서 응답한 Cipher Suites를 브라우저(Chrome)에서 처리할 수 없는경우

 1) IE, Edge, FireFox, Opera 등등 다른 브라우저를 사용해본다.
  - 브라우저마다 처리할 수 있는 Cipher Suites 종류가 다르다. (상세내용링크)
  - 이것마저 안되면 브라우저 사용자가 더이상 할 수 있는건 없다.
1004lucifer
 2) 서버관리자가 수정 할 수 있는 방법
  - 최신 프로토콜(TLS)을 사용할 수 있도록 WAS를 업그레이드 하거나 설정한다.
  - 대부분의 브라우저에서 지원하는 Cipher Suites를 사용하도록 셋팅한다. (상세내용링크)


댓글 없음 :

댓글 쓰기