Translate

2018년 11월 10일 토요일

[Apache/Tomcat] Tomcat Connector(mod_jk) 버전 확인방법





Apache와 Tomcat을 연동하는 Tomcat Connector의 1.2.44 이하 버전에서 취약점이 발견되어 최신버전으로 올리라는 지침이 내려왔다.



mod_jk.so 파일의 버전을 알아보는 방법은 아래와 같다.

1004lucifer
>$ strings /{_APACHE_PATH_}/modules/mod_jk.so |grep -i mod_jk
mod_jk.so
mod_jk.c
mod_jk/1.2.18





참고
 - http://tomcat.apache.org/connectors-doc/
 - https://sysadminupdates.com/blog/2010/03/04/go-back-linuxquestions-org-forums-linux-linux-newbie-reload-this-page-how-to-check-the-installed-mod_jk-version/

댓글 없음 :

댓글 쓰기